Acest modul nu a fost testat cu ultimele 3 versiuni importante ale WordPress. S-ar putea să nu mai fie întreținut sau susținut și ar putea avea probleme de compatibilitate când este folosit cu versiuni recente ale WordPress.

Proofreading

Descriere

Proofreading plugin allows you to improve the quality of your posts, pages and all your WordPress website.
It gives you the possibility to check the correction of the texts inserted into posts, pages and drafts in less than a second!

Press the „Analyze” button and you will have a list of all found errors.
The plugin allows to recognize different types of text errors (thanks to Languagetool.org). Here some examples of error types:
* Typos
* Punctuation
* Typography
* Commonly Confused Words
* Nonstandard phrases
* Semantic
* Grammar
* Redundant Phrases

Proofreading plugin supports a lot of languages. For example:
* English
* Spanish
* German
* Italian
* Japanese
* French
* Portuguese
* Russian
* and so on…

For every language, in the settings page, you can customize which are the error categories you are interesting, hiding the others.

Capturi ecran

  • This screen shot the Proofreading box inside a post edit page. Pressing the Analyze button you provide a text errors check for the enabled error categories of the selected language. Three buttons for every found error allows you to: Show the paragraph of the error, Hide the error or Hide all errors of this type.
  • When at least one error has been hidden, you can show again every hidden error.
  • How to access to settings page
  • Settings page. Here you can: Select your default language, Enable/Disable error categories to check for every language

Instalare

From your WordPress dashboard

  1. Visit ‘Plugins > Add New’
  2. Search for ‘Proofreading’
  3. Activate the plugin from your Plugins page.

From WordPress.org

  1. Download Proofreading zip file
  2. Unzip it
  3. Upload the unzipped directory to your ‘/wp-content/plugins/’ directory
  4. Activate the plugin from your Plugins page.

After installation the plugin select your WordPress installation language as default language for the plugin. If you want to change it, go to the settings page.

Verificări

21 ianuarie 2022 1 răspuns
The plugin is very useful. After errors in operation, a contact with author it was fastly and solved my doubts, following the spirit of FOSS. Long life to Proofreading!
25 februarie 2020
Please No Gutenburg in the new update, at least do it for me. I can't post anything, I can't repair anything. I don't even know how to keep going on. Please make it stop. I can't even know how to post on my own website. The issue is I don't know how to use Gutenburg and it's not user understandable.
26 februarie 2018
Il plugin aiuta a correggere il testo in corso d'opera, una importante funzionalità per editor e blogger. The plugin helps to correct the text when writing, an important feature for editors and bloggers.
23 februarie 2018 2 răspunsuri
I think it is very useful inside Wordpress world. All site must have it to avoid common text errors. It does not take up much space in the backend Wordpress console so it can always be left activated. P.S: I'm the autor of the plugin.
Citește toate cele 6 recenzii

Contributori și dezvoltatori

„Proofreading” este un software open-source. La acest modul au contribuit următoarele persoane.

Contributori

„Proofreading” a fost tradus în 2 locale. Mulțumim traducătorilor pentru contribuția lor.

Tradu „Proofreading” în limba ta.

Te interesează dezvoltarea?

Răsfoiește codul, vezi depozitarul SVN, sau abonează-te la jurnalul de dezvoltare prin RSS.

Istoric modificări

1.0.11

  • WordPress 5.8 compatibility (not Gutenberg)
  • Restyling of about page

1.0.10

  • WordPress 5.7 compatibility (not Gutenberg)
  • Classic editor link corrected

1.0.9

  • Enabled proofreading services for all post types
  • Plugin webpage changed
  • Minor changes

1.0.8

  • WordPress 5.6 compatibility (not Gutenberg)
  • Speed improvement (JS/CSS file loading)
  • Font Awesome icons replaced by Dashicons
  • Minor changes

1.0.7

  • WordPress 5.3 compatibility (not Gutenberg)
  • Code and documentation improvements
  • Minor changes

1.0.6

  • WordPress 5.2 compatibility (not Gutenberg)
  • Graphical changes

1.0.5

  • Security improvements
  • Graphical changes
  • Paragraph selection corrected
  • Removed jQuery $ alias use

1.0.x

  • Minor changes and bugfixes

1.0

  • First plugin version