Suport » Probleme și soluții » Nu imi face legatura cu baza de date

  • Salut. Am instalat Bitnami, am urmat pasii intocmai ca intr-un videotutorial. Dar, de fiecare data cand incerc sa intru in http://127.0.0.1/wordpress/ primesc eroarea asta: Error establishing a database connection.

    Am intrat in phpmyadmin, am facut o baza de date (db_wordpress), am un user (fulminator) si parola (abc123), are privilegii la maxim. wp-config imi arata asa:

    define('DB_NAME', 'db_wordpress');
    define('DB_USER', 'fulminator');
    define('DB_PASSWORD', 'abc123');
    define('DB_HOST', '127.0.0.1');
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    config.inc (configul serverului) imi arata asa:

    $cfg['Servers'] = array();
    $i = 1;
    
    $cfg['Servers'][$i]['host'] = 'localhost';
    $cfg['Servers'][$i]['port'] = '3306';
    $cfg['Servers'][$i]['socket'] = '';
    $cfg['Servers'][$i]['ssl'] = false;
    $cfg['Servers'][$i]['connect_type'] = 'tcp';
    $cfg['Servers'][$i]['extension'] = 'mysqli';
    $cfg['Servers'][$i]['compress'] = false;
    $cfg['Servers'][$i]['controluser'] = '';
    $cfg['Servers'][$i]['controlpass'] = '';
    $cfg['Servers'][$i]['auth_type'] = 'cookie';
    $cfg['Servers'][$i]['auth_http_realm'] = '';
    $cfg['Servers'][$i]['user'] = 'fulminator';
    $cfg['Servers'][$i]['password'] = 'abc123';
    $cfg['Servers'][$i]['SignonSession'] = '';
    $cfg['Servers'][$i]['SignonURL'] = '';
    $cfg['Servers'][$i]['LogoutURL'] = '';
    $cfg['Servers'][$i]['nopassword'] = true;
    $cfg['Servers'][$i]['only_db'] = '';
    $cfg['Servers'][$i]['hide_db'] = '';
    $cfg['Servers'][$i]['verbose'] = '';
    $cfg['Servers'][$i]['pmadb'] = '';
    $cfg['Servers'][$i]['bookmarktable'] = '';
    $cfg['Servers'][$i]['relation'] = '';
    etc...

    Pentru cine e nelamurit, am folosit 127.0.0.1 in loc de ‘localhost’ din simplul motiv ca nu imi permitea accesul la phpmyadmin; citind de pe forumuri am folosit aceasta solutie, insa… primesc aceeasi eroare. Pur si simplul wordpress-ul nu imi vede baza de date. Mentionez ca folosesc un router, ip-ul meu local este 192.168.0.3 (am incercat si cu ip in loc de 127.0.0.1 sau localhost – acelasi rezultat). Va rog sa ma ghidati spre o solutie. Va multumesc.

    update: mergand pe presupunerea ca nu imi recunostea userul ‘fulminator’ ca privilegiat pe baza de date, am folosit ‘root’ peste tot. Culmea, acum se face legatura intre baza de date, insa, cand incerc sa intru pe 127.0.0.1/wordpress/ imi intra automat in http://127.0.0.1/wordpress/wp-admin/install.php si imi da eroarea: Not Found
    The requested URL /wordpress/wp-admin/install.php was not found on this server.

    Bineinteles ca nu exista fisierul in folderul meu ‘wordpress’, dar nu ar trebui sa fie gata instalat? Sa il pun eu manual acolo? Mentionez ca folosesc WordPress Version 3.2.1. Multumesc

Vizualizare 2 răspunsuri - 1 la 2 (din 2 în total)
  • Inițiator fir de discuții fulminator

    (@fulminator)

    [Resolved]. Am descarcat wordpress-ul si am copiat fisierul ‘install.php’ unde trebuia si l-am instalat. Acum merge. Va rog sa ma scuzati de deranj, dar daca ati sti cat m-am chinuit cu XAMP si WAMP am ajuns sa cred ca e din cauza routerului problema mea. Noroc ca am dat peste Bitnami, il recomand cu caldura nubilor (ca mine) 🙂

    eu folosesc appserv, XAMP si WAMP au foarte multe setari care nu iti sunt necesare;))

Vizualizare 2 răspunsuri - 1 la 2 (din 2 în total)
  • Subiectul „Nu imi face legatura cu baza de date” este închis pentru răspunsuri noi.