Acest modul nu a fost testat cu ultimele 3 versiuni importante ale WordPress. S-ar putea să nu mai fie întreținut sau susținut și ar putea avea probleme de compatibilitate când este folosit cu versiuni recente ale WordPress.

Checking Variables (Dev. Tool)

Descriere

Are you a WordPress Developer? Just simply check the values of your variables. You can use it either in Query Monitor result and independently.

Utilizare

  1. Using console( $var [, $var [, $var]] … ); function, you can check what the variable contains.
  2. You can check it on the Query Monitor – Variable Checking or your wp_footer.

Capturi ecran

  • Opțiuni
  • Position on Query Monitor
  • Result on Query Monitor
  • Result on Footer
  • Result on Javascript Console

Instalare

Din panoul tău de control WordPress

  1. Vizitează „Module > Adaugă modul”
  2. Search for ‘Checking Variables’
  3. Activate ‘Checking Variables (Dev. Tool)’ from your Plugins page.

De la WordPress.org

  1. Download the plugin zip package and extract it.
  2. Put the folder named „query-monitor-check-var” under /wp-content/plugins/ directory
  3. Go to the plugins page in your WordPress admin panel and click „Activate”

Verificări

18 februarie 2019
Has a few small quirks but still a nice companion to any debugging outfit. Works fine with WP v5.0.3 and all of the latest updates from QM.
Citește o recenzie

Contributori și dezvoltatori

„Checking Variables (Dev. Tool)” este un software open-source. La acest modul au contribuit următoarele persoane.

Contributori

Istoric modificări

4.0.0

  • Fix Some Errors
  • Fix Interface

3.0.5

  • Fix Errors : When check value with brackets (ex. console( $somevar . ” got it!” ) )

3.0.4

  • Fix Errors

3.0.3

  • Fix Error : Protected and Private Key Error

3.0.2

  • Fix Some Error

3.0.1

  • Fix Plugins Page Setting Link
  • Fix Javascript Console Error

3.0

  • Improvement
  • Output Style : Show Variable Name, Show Variable Location
  • Javascript Console Screen
  • Capability Control

2.0

  • Make it can be used independently.

1.0

  • Original Version