Acest modul nu a fost testat cu ultimele 3 versiuni importante ale WordPress. S-ar putea să nu mai fie întreținut sau susținut și ar putea avea probleme de compatibilitate când este folosit cu versiuni recente ale WordPress.

CodeMirror for Post Editor

Descriere

This plugin adds an editor button that will let you use the great CodeMirror editor to edit the HTML code of your posts.

This editor supports code coloring and automatic tag closing on a big editor that will let you write beautiful code on your WordPress posts.

Probably the best choice if you need to use complex HTML on your posts, or just enjoy writing in plain HTML.

Capturi ecran

  • You can use the CodeMirror editor activating the editor toolbar icon
  • The editor opens on a big and wide dialog, so you can focus on your code

Instalare

  1. Upload the plugin
  2. Activate the plugin through the ‘Plugins’ menu in WordPress
  3. Done! You can use it

Întrebări frecvente

What browsers can run CodeMirror?

The following desktop browsers are able to run CodeMirror:

  • Firefox 3 or higher
  • Chrome, any version
  • Safari 5.2 or higher
  • Opera 9 or higher (with some key-handling problems on OS X)
  • Internet Explorer 8 or higher in standards mode.
  • Internet Explorer 7 (standards mode) is usable, but buggy.
How can I contribute with an idea or feature request? Where can I report bugs?

Checkout my project repository on GitHub

Verificări

Nu există nicio verificare pentru acest modul.

Contributori și dezvoltatori

„CodeMirror for Post Editor” este un software open-source. La acest modul au contribuit următoarele persoane.

Contributori

Istoric modificări

0.4.1

  • Backwards compatibility fix for WordPress 3.8

0.4

  • Fixed for compatibility with WordPress 3.9
  • Optimized loading of some scripts
  • Changed the toolbar icon for one of WordPress Dashicons
  • Some very minor styling fixes

0.3

  • Updated CodeMirror version to 3.2.0
  • Fixed z-index issues with the new WordPress image library (and… using the new library methods instead of the old uploader)

0.2.1

  • Load scripts on all post-types

0.2

  • Fixes uncorrect line breaks inside lists and other elements

0.1

  • First working version, fairly complete